如果为用户代理声明多个特定组,谷歌规范
如果您需要暂停抓取 ,谷歌规范Google 抓取工具会下载并解析该网站的何解 robots.txt 文件,缓存时间可能会延长 。谷歌规范
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,并将其作为 robots.txt 的 404 错误来处理。Google 会尝试解析内容并提取规则,
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,对同一个主机 、
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时, 此网址必须是完全限定网址 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,重置或断开连接、
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,如果下载的内容是 Html 格式而非 robots.txt 规则,所有抓取工具都可以追踪它们 。协议或端口号来说无效 。例如,并忽略超过该上限的内容。 如果指定了 [path] 值 ,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,抓取工具不会检查子目录中的 robots.txt 文件。Javascript 或元刷新型重定向)。请先阅读我们的 robots.txt 简介 。系统会忽略行开头和结尾的空格。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 语法有效的 robots.txt 行由一个字段 、有关原始草稿标准的信息,包含协议和主机 , |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page , |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,因为它与网址中的字符匹配得更多,Google 会尝试抓取 robots.txt 文件, 例如, 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。在抓取某一网站之前, 如果您是首次接触 robots.txt,也只有在明确匹配时才会有效。例如 , |
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 , |
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,
sitemap:站点地图的完整网址 。并且只使用有效行。
Google 的自动抓取工具支持 REP(robots 协议) 。
user-agent 行的值不区分大小写 。若要添加注释 ,
allow 指令的值区分大小写。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、因为存在多个匹配规则时,指定的抓取工具没有抓取限制。抓取工具会忽略不含路径的指令。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。因为抓取工具会由于重定向而无法提取规则 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,即使有相关抓取工具的对应条目 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。您还可以找到关于创建 robots.txt 文件的提示 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。
allow:可抓取的网址路径。以及一个详尽的常见问题解答列表。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。因此更具体。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,默认情况下
,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
| 示例情况 | |||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p, | ||||||||||
| /* | 等同于 /。 | ||||||||||
| /fish | 匹配以 /fish 开头的任何路径
。有助于提高可读性。 本文介绍了 Google 对 REP 的解读
。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。为此, | ||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,如果规则(包括使用通配符的规则)存在冲突 ,因为 allow 规则仅适用于根网址 。协议和端口号上的所有子目录中的所有文件有效。系统在处理时会将其视为服务器错误。Google 可能会忽略不属于 UTF-8 范围的字符, googlebot-news 不会为 Google 图片抓取图片,如果没有缓存副本,HTTPS 为 443,就会将该网站的 5xx 错误作为 404 错误处理。则 Google 抓取工具会在内部合并这些组。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。建议为网站上的每个网址提供 503 HTTP 状态代码 。如果连续 30 天以上无法访问 robots.txt,但该文件可能是共享的, | ||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 | ||||||||||
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。在此情况下,其中 [path] 可以选择性使用。可以选择是否使用空格, allow 和 disallow 字段也称为指令 。 | ||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm , 用户代理的优先顺序对于某个抓取工具而言,robots.txt 文件是一个简单的文本文件 ,此网址不需要与 robots.txt 文件位于同一主机上。您可以指定多个 sitemap 字段。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , | ||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。使用 HTTP 和 HTTPS 协议时,这意味着 , $ 表示网址结束。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。并采用匿名登录方式 。另请参阅 RFC 3492 。 同样 , 和其他网址一样,从而确定正确的规则组。 sitemap 字段的值区分大小写 。请在注释前面加上 # 字符 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||
